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Read GPS Log From Device
Step 1 — Connect Data Logger to PC USB port. Please make sure the Data
Logger power is turn on.

Step 2 — Menu command “File” -> “Read log...” Users have to input product
key at the first time. The product key is on the cover of installation CD.

Product Key X

Please enter the product key:

OK

Cancel

Connecting to GPS module. ..

Connecting ko GPS module. ..
Scan 6kh comport with 19200 baudrate (20003, ,,

L Cancel i

GPS Photo Tagger will automatically detect the port and baud rate and read in
the GPS tracks.

A track list window will be popped up. Select the tracks to import.

Select Track X
Please select tracks to add to current project:
| | Track Mame Skart Time End Time Tokal Dis...
v | Track0903_1253 Qf3/2007 8:55:49 PM  9/3)2007 9:22:24 PM 5.3 km
v| Trackosn4_0z246 Q/4/2007 10:46:10 AM  9/4)2007 3:02:09 PM 11.0km
V| Track0a0s_0346 Q52007 11:46:11 AM  9/S)2007 2:15:37 PM 4.0 km
V| Trackoo0s_0740 9/S/2007 3:40:45 PM 9/S)2007 5:00:51 PM 12.2 km
V| Trackoo0s_1232 Q/Sf2007 §:32:41 PM 9/SJ2007 9:02:54 PM 1.4 km
v| Track0o07?_0414 Qi7f2007 12:14:30 PM 9f7/2007 1:26:48 PM 12.4 km
¥| Tracko90?_0&51 Q712007 2:51:54 PM 97)2007 3:23:14 PM 12.6 km
v| Track090s_0s0s Qf3/2007 1:05:04 PM 98)2007 1:17:49 PM 3.1km
v| Track090s_0654 Q82007 2:54:29 PM 98)2007 2:58:12 PM 429 m
V| Trackoo0s_0s06 9312007 4:06:30 PM 9/8)2007 5:23:48 PM 3.9 km
oK Cancel
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Tracks will be shown on the Google Map window.

{2) GPS Photo Tagger* - GPS Photo Tagger =EIEDG

fle Photo Track Tooks Help
Display Time Zone: |(GMT+08:00) Taipei !

S| 9% 0 E) LSS

G ack Edior |

Photo View | Photo List | Altitude View | Speed View | Track List |

— Track Name: |Start Time |End Time |Duration
TrackD903_1253 - 9/3j2007 8:53:49 PM  9{3/2007 9:22:24 PM 0 Days 00:28:35
Track0904_0246 - 9/4/2007 10:46:10 AM  9/4/2007 3:02:09PM 0 Days 04:15:59
TrackD905_0346 |- |9/5/2007 11:46:11 AM  9/5/2007 2:15:37 PM 0 Days 02:29:26
TrackD905_0740 - 9/5/2007 3:40:45PM  9/5/2007 5:00:51 PM 0 Days 01:20:06
Track0905_1232 |-+ 9/5/2007 8:32:41 PM  9/5{2007 9:02:54 PM 0 Days 00:30:13
TrackD907_0414 - |9/7/2007 12:14:30 PM  9/7/2007 1:26:48PM 0 Days 01:12:18
TrackD907_0651 | -(9/7/2007 2:51:54 PM  9/7/2007 3:23:14PM 0 Days 00:31:20
Track0908_0S05 |-+ 9/8/2007 1:05:04 PM  9/8{2007 1:17:49PM 0 Days 00:12:45
TrackD908_0654 - 9/8j2007 2:54:29PM  9/8/2007 2:58:12PM 0 Days 00:03:43
TrackD908_0806 - 9/8/2007 4:06:30PM  9/8/2007 5:23:48 PM 0 Days 01:17:18

|« i ] »
iLaﬁtud:: 31°1315"N Longitude: 121°23'11"E 7

Add phatos from files

Clear Data Logger Memory
Menu command “File” -> “Clear log” will clear the data stored in device, so the

device memory are enough for next usage.

-,

GPS Photo Tagger @

\ ? ) Are you sure wou wank ko clear all data?

Data Logger Configuration

Connect Data Logger to PC and turn on Data Logger. Menu command “File” ->
“Config GPS...” If Data Logger is not connected, the GPS Log Setting area will be
disabled. Please make sure the Data Logger power switch is turn on when connect.



Configure GPS module X

~Connection Setting
# | Auto Scan GPS Module

Reconnect...
Manual Setting

COM pork:

~GPS Log Setting

+ General & m

Log Criteria:

v | Log every 5| seconds

Log every 0| meters

Log over 0] kmfh

~Data Log Memory
5 % Memory Used
=3

0K Cancel

Connection Setting:

Auto Scan GPS Module (Recommended)

The program will automatically detect the com port and the baud rate. It is
recommended to set to auto scan.

Manual Setting

Users can also manually set the port and baud rate. Although it can speed up the initial

connect time, but it is not recommended unless users understand the valid port and
baud rate.

GPS Log Setting

There are 4 log modes: General mode, vehicle mode, cycling mode, and
hiking mode. Users can also change the default setting of these 4 modes.

Log every () seconds:



If the criterion is checked, Data Logger will not log if difference between current
time and last logged time is less than the specified time.

Log every () meters:

If the criterion is checked, Data Logger will not log if the distance of current
position and last logged position is less than the specified distances.

Log over () km/h:

If the criterion is checked, Data logger will not log if the speed is under the
setting.

Data Log Memory

A bar show how many percentage of memory is used in the Data Logger
device. Users can use “Clear Log” to clear all the memory.
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S alides —
uxelles - | "Map | Satelllte | Hw,fbnd B
.I}I)Iél'e Namur:i=ss = W —
r:,;::.b:a Q'._ ) ! 4 @

b =‘-Jd|

[Add Pfacemarkl

YT

\Aezneres ““ Luxem

bourg ;
o TS
ongﬂy//

Thlonv'"e? Saarloust“- / H

To add a new place mark, please click on the blue balloon icon, and then
click on the position of new place marker. The “Place Mark Property” dialog
will be pop up for editing.



Place Mark Property x

Mame: | My PlaceMark
PS5 Info
DatefTime: -

Latitude: 49°15'13"N
Longitude:  4°1'55"E
Alkibude:

Photos:

Description:

(114 Cancel

Save as Target

(Only support in model “Travel Honey”) To save the place marker as the
target of Travel Honey, please click on the place mark, and click on the
“Save as target” link.
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A message box will be pop up when it is successfully saved into the device.



GPS Photo Tagger

L E Successful bo save Place Mark. 1 as target!
L

Add Photos
Users can add photo from a file folder, or selected files.

Add photo from a folder: Menu command “Photo” -> “Add Photo...” ->
“From Folder”. Select a folder to add photo.

Add photo from selected files: Menu command “Photo” -> “Add Photo...” ->
“From Files”. Use Ctrl-Click, or Shift-Click to select multiple files.

The photo will show on the Photo View window. Users can add comments
to each photo. Users can also rotate, delete photo.

|Ready Latiude: 402140 Longkude: 115°5342°E

When photos are added, GPS Photo Tagger will automatically match photo
and GPS logged waypoints by time. Place marks will be created as a
placeholder for photos.
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Browse photos

Click on the “next photo” and “prev photo” buttons to browse the photos.

Current photo and current place mark will be synchronized.
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Photo View | P Lsl | Al View | Speed View | Prpssy

GeoTag - Save GPS Information into Photos

Menu command “Photo” -> “Write GPS info into photos” will save the
latitude, longitude, and altitude into photo.

A progress window will show the writing progress.



Ml‘llll’lg cpg 'II'III] II'IID p"ulus... E

‘wriking GPS info into phaokos. .
P1000043, PG

EEEEES ]  Cancel j

Photo List Window
Photo list window will show the attributes of photos. The information includes
“file name”, “date”, “place mark”, “latitude”, “longitude”, and “Geotagged
flag”.

06_BsiHalAn® - GPS Phato Tagger o B

Photo Track Tools Help

Display Time Zone: | [GMT+08:00) Taipsi - | !

PhotaView | Phota List | Alitude View | SpeedView | Tiack List |
[ Map | Satslite T |Phntn Marme |Date |Place Mark |Latitude: |Longitude =
SAMYONSL.IPG QBI2007 12:22:12 PM 31 25°15'49"N 121°37'5t
SAMYONSZ, PG Q62007 12:29:01 PM 32 25°17°25"N 1210352
SAMYONS3. PG QBI2007 12:29:25 PM 33 25°17°33"N 121°35'1

SAMYONS4, PG Q62007 12:31:55 PM 34 25°17'47"N 121°34'1(
SAMYOOSS, PG 9f8j2007 12:35:27 PM 35 25°17'36"N
SAMYODSE, PG 9/6/2007 12:36:55 PM 36 2571733

SAMYODSE, PG 1612007 1:00:15 PM 38 25°16'58"N
SANYODSS, PG 9/6/2007 1:00:56 PM 39 25°16'58"N
f6f
f6f

] uyd
| Baishawan
SANVODED.JPG  9/6/2007 LOLOSPM 40 25°16'58"
SANVODELJPG 962007 LDL:19PM 41 25°16'58"
SANVODEZ. PG 9/8/2007 LDL4OPM 42 25°16'58"
SANVODE3.JPG  9/8j2007 LIOLIS3PM 43 2501658
SANVODE4.JPG  9/8j2007 LiDZ:I14PM 44 2501658
SANVODES.JPG  9/8j2007 1:0Z:I25PM 45 2501658

caronnce we ozenne e T
< m \

Photo Hame | SANVOOS7.JPG
Date/Time  |9/6/2007 12:58:19 PM

Make SAMVO Electric Co.,Lkd,
@ = Modsl =3}
@ .5 .‘i FlashUsed  |Ho

Focal Length & mm

Baishawan

Exposurs Time | 1/170 st
Aperture F3.0
150 Equivalent |50
Exposurs Bias |0.0

Latitude: 31°13'15"M LDHH\tudE: 121°2311'E

Upload Photos to Flickr
Menu command “Photo” > “Upload Photos to Flickr...” will invoke upload
wizard. Users can set “Title”, “description”, “Tag”, “Public or Private”, and
“Upload photo size”.



Upload Account Setting

Account Name:

Privacy Setting:
! Public
Private
Open for friends
Open for family

Adjust Uploaded Photo Sizes: (Max Photo Edge)
1280 pixels

Upload Phato Setting

Please select photos to edit photo options:

IMG_2419.JPG

IMG_2420.IPG

IMG_2421.IPG

=

IMG_2423.0PG IMG_2424.PG

L fa T

B 1/21 selécted

1MG_2422.PG

< Back

Title:
Rig

Description:

FIRRERRRR e B

Tags:
Rig

Bext > Finish Cancel

v

If you want to upload geotagged photos directly on Flickr web site:

You have to turn on the following option. "Your Account">"Privacy &

Permissions">"Import EXIF location data: Yes"

After the option is turned on, the uploaded photo will be put on map.

Go to Flickr > “You” > “Your map”, you can browse your photos on the map.

Shift Photo Time

Menu command “Photo” -> “Shift photo time...” will invoke the shift photo

time window. All the photo will be added (or subtracted) the specified time.
The dates are saved in the Exif parts of Jpeg or Tiff file. After the shift, GPS
Photo Tagger will automatically match the photo and track waypoints again.

User can put more than 365 in days.

Shift Photo Time

(o} +

Ddays Ohours

O minutes

0| seconds

OK Cancel




Photo Comments
Support multi-language comments. The comments will be uploaded to Flickr,

packed in the kml file.

{2) Trackn706 - GPS Photo Tagger = ETEG
File GPS Photo Track Tools Help

a2 N IE
M\ Track Editor | i

[ wap | Satelite | Hybrid |

Display Time Zone: | (GMT+08:00) Taipei !

Photo View | Photo List | Altitude View | SpeedView | Froperty |

P10000S8.3PG > ~
E 716/2007 7:21:40 PM

-

Comments:

FRAERFSERTREIEIRLE]

| Location Info %

Google Earth Viewing
Command “File” -> “View in Google Earth” will invoke Google Earth to view
the tracks and photos. Users have to install the Google earth.
http://earth.google.com/

X

Fie Edt View Tools Add Hel

Tiananmen
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-| (3 mossottpome... | & wstracer (hu... | @ Tra



http://earth.google.com/

Save As KMZ File
Menu command “File” -> “Export as Kmz...” to save the tracks and photos in
kmz file. You can import kmz file to Google Earth. You can also send kmz file to
friends to share their trips with friends as long as they have installed Google
Earth on their computers.

The picture size packed in the kmz file can be set in the options dialog. Menu
command “Tools” -> “Options” > “Google Earth” > “Photo size in KMZ”.

Altitude Graph

Switch to “Altitude View” window will show the altitude graph. The waypoints
with photos on it will be marked with red square. Moving cursor on red square
will display the photo. You can pan left, pan right, zoom in, zoom out in the
altitude graph.

oto View | Photo List | Altitude View. | Speed View | Property
(1/1) Track0709_0844

Speed graph

Switch to “Speed View” window will show the speed graph. The waypoints with
photos on it will be marked with red square. Moving cursor on red square will
display the photo. You can pan left, pan right, zoom in, zoom out in the altitude
graph.



12) Track0709* - GPS Photo Tagger - 0O X
Blo oo Irack Teos Help

> Q iy @:§ ] | Displey Time Zow: | (GMT+08.00) Tapei l

Google Map. | Track Edicr | | PhotoView | ProtoLList | Atude View |[Speed View| Pcpesty |

(1/1) Track0709_0844

120km/h 10:00 AM 11:00 AM 12:00 PM

(104km/h) 11:34:59 AM
100km/h

80km/h

40km/h

20km/h

J‘:ﬂ-,-'-j“wﬁ.-, =

L P,
03:00 AM 10:00 AM

Track Editing
Switch to folder “Track Editor” on the left window. Move the cursor on the
track will show the preselected waypoint time. Click on track to select the
whole track.

[2) Track0708* - GFS Photo Tagaer = O X
Ble FPhote Track Tools Help

> f) iy ‘ @ ‘ @ Display Time Zane: | (GMT+0:00) T aipei !
Gosgle Map | Track Editor | Photo View |[Pheto List | Alitude View | Speed'View | Fropety |
[Photo Name [Date [Place Mark |tattude JLongiude |c| ~
+ PI00036%. PG 7/9(2007 9:14:27 AM 3 40208 116023
= PIOOO3ES, PG 743j2007 9:14:39 A 1D 21
PI0003E6. PG 73[2007 Si1S:06 AM 11 218
PI0ON3S7. PG 7/3j2007 3:39:43 AM 12 21z
PI0003EB.IPG  7/3/2007 9:3955 AM 12 0212
PIOONEO. PG 7/3j2007 9:40:33 AM 12 o212
PIOONG7OPG  7/3j2007 9:41:34 AM 13 212’
PIOOOGTLIPG  73[2007 9142102 AM 19 21
PIOONGTZIPG  7/3j2007 3:42:43 AM 14
PIOOOG73PG  7A3j2007 3:49:00 A 15
A ;2% P1000574.37G 745/2007 9:49:14 4M1 16
e PI0ONG75.PG  7/3j2007 3:49:38 AM 17
¥ P1000376. 16 29/2007 9:50:12 AM 18
é; PI0ON77.0PG  7/3j2007 3:54:58 AM 19
i PI000G78,PG  7/3j2007 10:05:07 A 20
/ pImMMye. PG My imnsaRa 7t NSNS 11 EF - T
L Photo flame |P1000377. PG
Track0709_0844 DatefTime | 7/9/2007 9i54:56 A
41ﬂ 7/9/2007 9:22:07 AM = Make. [Panasonic
T Vodel oMCLx2

FlashUsed  [No

Focal Length |6 mm
R Expostre Time |1/400 sec

18 Aperture 7.0

® 150 Equivalert |100

Exposure Bias [0.0

|Latitude: 40°21'3'Y Longitude: 116°020°E )

Mouse right button menu command “Delete this point” will delete the
selected waypoint. Mouse right button menu command “Delete Selected
Object” will delete the selected track.
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Delete this point
K Delete Selected Object

_j Properties
(u]=)
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Save and Open Project

Menu command “File” -> “Save project” will save the tracks and photo as a
project file.

Menu command “File” -> “Open project...” will open the saved project. The

project, photos, and photo comments will be restored after the project
opened.

Time Zone Setting

There are two time zone settings in “GPS Photo Tagger”. One is “Photo time
zone”, the other is “Display time zone”. “Photo time zone” is set to the same
time zone of your digital camera. The “Display time zone” is set for displaying
purpose. For example, If you are an Englishman and you travel to United State.
The “Photo time zone” should be set to “England” because your digital camera

time zone is in England, and the display time zone should be set to “United
State”.

The “Photo time zone” by default is set to the PC default value. In most of the
case the default value is correct.

Menu command “Tools” -> “Options” will invoke the options dialog. You can
set “Photo Time Zone” in the dialog.



Options X

~Unit and Coordination

Distance unit: Metric LatfLong: (¢ Degrees, Minutes, Seconds | ' Degrees

-Photo

Photo Time Zone: (GMT+08:00) Taipei

Max photojtrack diff time: 120 minutes

~Google Earth
Phato size in KMZ: 240 | pixels

~Display Language

Preferred Language: English &

0K Cancel

The “display time zone” setting is in the status bar.

Dizplay Time Sone: | [GMT+08:00] T aipei !

Options

)

Menu command “Tools” > “Options...”

Options X

~Unit and Coordination

Distance unit: Metric Lat/Long: () Degrees, Minutes, Seconds Degrees

~Photo

Photo Time Zone: (GMT-+08:00) Taipei

Max photojtrack diff time: 120 minutes

S GooglsEatth——————————————————————— - =
Phota size in KMZ: 240 pixels ‘

~Display Language
Preferred Language: English, ™ ‘

OK Cancel

Distance unit:
Metric: Kilometer / meters will be used for displaying.
Imperial: Miles / feet will be used for displaying.
Lat/Long:
Degrees, minutes, seconds: Latitude and longitude will be display like 23°12’20”

Degrees: Latitude and longitude will be display like 23.22152°



Photo Time Zone:
The time zone of your digital camera time setting
Max photo/track diff time:

The setting is used to match photo and track waypoints. Photo Tagger will match photos
and waypoints by time. It will find the nearest waypoint time to locate the photo. Yet, if
the closest waypoint time is more than the “Max photo/track diff time”, it will not
match the photo.

Photo size in KMZ:

The size of the photos packed in the KMZ file. It is related to the command “File” >
“Export As KMZ...”

Preferred Language:

Set the languages for menu, buttons and messages.



